[Résolu]Impossible de merger les manifest

Toutes les questions sur le développement Mobile, y compris la partie script.
Leuprochon
Messages : 56
Inscription : 04 Déc 2017 19:12

[Résolu]Impossible de merger les manifest

Message par Leuprochon » 12 Oct 2020 10:40

Bonjour à tous,

Alors je ne sais pas pourquoi mais soudainement je ne peux plus compiler mon application du jour au lendemain...

Voilà ce qu'il me met :

Manifest merger failed : Attribute meta-data#com.google.ar.core@value value=(required) from [:unityLibrary] AndroidManifest.xml:95:13-37

Et voici les explications :

Attribute meta-data#com.google.ar.core@value value=(required) from [:unityLibrary] AndroidManifest.xml:95:13-37
is also present at [:vlsdk:] AndroidManifest.xml:52:13-37 value=(optional).
Suggestion: add 'tools:replace="android:value"' to <meta-data> element at AndroidManifest.xml:93:9-95:40 to override

Et mon manifest (j'ai bien rajouté la partie : 'tools:replace="android:value"', j'ai également modifié la valeur android:value. Initialement elle était sur True, j'ai essayé optional et required mais ça fait la même chose )

Code : Tout sélectionner

<?xml version="1.0" encoding="utf-8"?>
<manifest
    xmlns:android="http://schemas.android.com/apk/res/android"
    package="com.unity3d.player"
    xmlns:tools="http://schemas.android.com/tools"
	android:installLocation="preferExternal"
    android:versionCode="1"
    android:versionName="1.0">
    <supports-screens
        android:smallScreens="true"
        android:normalScreens="true"
        android:largeScreens="true"
        android:xlargeScreens="true"
        android:anyDensity="true"/>

    <application
		android:theme="@style/UnityThemeSelector"
		android:icon="@drawable/app_icon"
        android:label="@string/app_name"
        android:debuggable="true">
        <activity android:name="com.unity3d.player.UnityPlayerActivity"
                  android:label="@string/app_name">
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />
                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
            <meta-data tools:replace="android:value" android:name="unityplayer.UnityActivity" android:value="required"/>
        </activity>
    </application>
    <uses-permission android:name="android.permission.CAMERA" />
    <uses-feature android:name="android.hardware.camera" android:required="true" />
    <uses-feature android:name="android.hardware.camera.autofocus" android:required="true" />
    <uses-feature android:name="android.hardware.camera.front" android:required="true" />
    <uses-feature android:glEsVersion='0x00020000' />
    <uses-feature android:name="android.hardware.touchscreen" android:required="false" />
    <uses-feature android:name="android.hardware.touchscreen.multitouch" android:required="false" />
    <uses-feature android:name="android.hardware.touchscreen.multitouch.distinct" android:required="false" />


</manifest>
Si quelqu'un aurait une idée ça serait super. Je ne comprends pas pourquoi ça ne veut plus fonctionner ...

Merci bien !

Leuprochon
Messages : 56
Inscription : 04 Déc 2017 19:12

Re: [Résolu]Impossible de merger les manifest

Message par Leuprochon » 12 Oct 2020 16:18

Bon ben j'ai trouvé (du moins pas vraiment mais j'ai plus le soucis).

A force de faire des essais entre différents SDK etc il y a du y avoir des problèmes entre eux. Donc j'ai exporter tout mon projet en package avec uniquement les trucs utiles. Ça a fait le ménage et finalement j'ai plus de soucis !

Je pense que le problème était entre Vuforia et VisionLib mais je ne suis pas sûr. C'est des problèmes entre librairies mais n'arrivant pas à trouver lesquelles et comment fixer le problème j'ai préféré partir sur une base saine !

Bonne journée (:

Répondre

Revenir vers « Développement plateformes mobile Iphone et Android »