[Résolu] Compatibilité Anciennes versions Android

Toutes les questions sur le développement Mobile, y compris la partie script.
Aelhan
Messages : 67
Inscription : 11 Déc 2019 23:00

[Résolu] Compatibilité Anciennes versions Android

Message par Aelhan » 26 Jan 2020 14:04

Bonjour,

Développant actuellement un jeu Android (je n'ai pas de terminal Ios pour faire des tests, donc ça viendra plus tard...), j'ai voulu installer l'apk sur la tablette de ma fille (elle m'a généreusement proposé de m'aider à traquer les bugs et proposer des évolutions la maline ;) ).
Et là, surprise, après l'installation, j'ai un petit message d'erreur qui me dit "Your device does not match the hardware requirements of this application" et si je continue malgré tout l'exécution, j'ai un magnifique écran tout rose, rien de plus. La tablettes est une Galaxy tab E , elle tourne sous Android 4.4.4 qui pourtant est le minimum requis dans mes paramètres de build.
J'ai vu sur le forum que certains parlaient des paramètres de shaders, mais je suis sur un petit jeu en 2D et n'ai rien d’extraordinaire niveau graphisme, alors je me demande comment rendre mes builds compatibles sans problème avec les vieux terminaux ?
D'avance merci pour vos réponses !
Dernière édition par Aelhan le 27 Jan 2020 15:13, édité 1 fois.
Celui qui pose une question risque cinq minutes d'avoir l'air bête.
Celui qui ne pose pas de question restera bête toute sa vie.

Avatar de l’utilisateur
boubouk50
ModoGenereux
ModoGenereux
Messages : 5301
Inscription : 28 Avr 2014 11:57
Localisation : Toulouse

Re: Compatibilité Anciennes versions Android

Message par boubouk50 » 27 Jan 2020 09:41

Salut,
Peut-être est-ce un souci de paramètres des build settings. Il ne faut pas juste mettre un minimum API mais aussi faire en sorte que l'hardware supporte tout le reste: shader, API graphique, etc.
Passe en Gamma et Auto Graphics API. Aussi, il faut compiler en 32 bit.
Utilises-tu l'accéléromètre, le GPS ou le gyroscope?
"Ce n'est pas en améliorant la bougie, que l'on a inventé l'ampoule, c'est en marchant longtemps."
Nétiquette du forum
Savoir faire une recherche
Apprendre la programmation

Aelhan
Messages : 67
Inscription : 11 Déc 2019 23:00

Re: Compatibilité Anciennes versions Android

Message par Aelhan » 27 Jan 2020 12:38

Merci de ta réponse, non je n'utilise rien de tout ça, ce n'est rien qu'un bête idle game en 2D. En revanche j'ai téléchargé tous les api de 4.4 à la plus récente dans mon gestionnaire de sdk, et lorsque j'essaie de build en version cible 5.0 j'ai un sacré paquet d'erreurs (la je ne suis pas sur l'ordi donc je ne peux pas détailler). Je referai un test avec les 3 paramètres que tu suggères et je reviens donner le résultat. Encore merci.
Celui qui pose une question risque cinq minutes d'avoir l'air bête.
Celui qui ne pose pas de question restera bête toute sa vie.

Aelhan
Messages : 67
Inscription : 11 Déc 2019 23:00

Re: Compatibilité Anciennes versions Android

Message par Aelhan » 27 Jan 2020 15:12

Alleluia, au final je n'ai eu qu'à cocher l'auto graphie API puisque les 2 autres étaient déjà ok. Et ben oui, ça fonctionne nickel, ma fille est déjà au "boulot" du coup ;)
Merci et bonne journée !
Celui qui pose une question risque cinq minutes d'avoir l'air bête.
Celui qui ne pose pas de question restera bête toute sa vie.

Répondre

Revenir vers « Développement plateformes mobile Iphone et Android »