[Résolu]Clic souris ne fonctionne plus une fois compilé

Règles du forum
Attention, si vous postez un lien vers un package (en guise d'exemple), assurez-vous qu'il ne contient que des éléments personnels et/ou libres de droit (donc sans l'asset PlayMaker dedans)

Sinon c'est assimilé à du piratage par diffusion sans autorisation de contenus protégés

Les modos auront alors comme consigne de carrément supprimer votre question
Avatar de l’utilisateur
stigma
Messages : 1130
Inscription : 17 Nov 2012 18:29
Localisation : Perdu dans les mondes de Myst
Contact :

[Résolu]Clic souris ne fonctionne plus une fois compilé

Message par stigma » 27 Déc 2016 12:19

Salut,
ça m'a l'air bien désert. Je sais que Jean Fabre n'est pas venu depuis longtemps, mais je pose quand même ma question, on ne sait jamais !

J'ai un menu où il faut cliquer pour lancer d'autres scènes.
J'utilise Set Mouse Cursor
Tout marche bien mais une fois compilé, le clic souris ne marche plus.

Si je zappe le menu lors de la compilation, la scène principale se lance et le clic souris marche bien, toujours en utilisant Set Mouse Cursor.

J'en perds mon latin !

Si quelqu'un a une idée, je lui offre un café. Ou un Single Malt !
Dernière édition par stigma le 22 Jan 2017 18:46, édité 1 fois.

Avatar de l’utilisateur
Thyriax
Messages : 221
Inscription : 09 Mars 2011 11:57
Contact :

Re: Clic souris ne fonctionne plus une fois compilé

Message par Thyriax » 27 Déc 2016 18:27

Salut Stigma,
J'ai d'abord une petite question qui me semble bête, mais je la pose quand même.
As-tu utiliser le système "Ugui Pointer Proxy Event" pour faire ton menu?
https://www.youtube.com/watch?v=KZCtGySZ4AI
Ensuite, lorsque j'ai du faire un menu 2d pour un jeu, j'ai utilisé l'action "Set Cursor Mode" pour le contrôle du pointeur de souris, et non pas "Set Mouse Cursor". Peut-être que le problème vient de là.

Bien sûr, cela reste des hypothèses.
++

Avatar de l’utilisateur
stigma
Messages : 1130
Inscription : 17 Nov 2012 18:29
Localisation : Perdu dans les mondes de Myst
Contact :

Re: Clic souris ne fonctionne plus une fois compilé

Message par stigma » 27 Déc 2016 19:31

Pour mon menu, j'utilise une scène normale.
J'ai remplacé Set Mouse Cursor par Set Cursor Mode mais ça ne change rien.
Image
Quand le curseur survole une zone, ça allume un spot. Mais compilé, ça ne marche plus non plus.

Edit :
J'ai fait une autre scène et plus de problème.

Répondre

Revenir vers « Vos Questions »