Le bras de mon perso se décale quand je lance l'anim

Zenden
Messages : 1
Inscription : 11 Mars 2018 12:51

Le bras de mon perso se décale quand je lance l'anim

Message par Zenden » 11 Mars 2018 13:00

Salut, enfaîte comme dit dans le titre j'ai un soucis au moment ou j'appuie sur la touche pour lancer l'anim ( la touche "H" ).

Voici une vidéo pour mieux détailler :
https://www.youtube.com/watch?v=R9RzGiYkvaY&feature=youtu.be

Et le script, je précise que hier j'ai utilisé le même script sur un autre projet et qu'il m'est arrivé le même bug que j'ai réglé par hasard mais j'ai malheureusement oublié...

Code : Tout sélectionner

    //Variable
    private Animation Anim;

	// Use this for initialization
	void Start () {

        Anim = GetComponent<Animation>();
		
	}
	
	// Update is called once per frame
	void Update () {

        // Coup arme

        if(Input.GetKeyDown(KeyCode.H))
        {
            Anim.Play("swordhandanim");
        }
		
	}
}
Si il y a besoins de plus de détail ou de screen je les donnes volontiers.

Avatar de l’utilisateur
boubouk50
ModoGenereux
ModoGenereux
Messages : 4469
Inscription : 28 Avr 2014 11:57
Localisation : Toulouse

Re: Le bras de mon perso se décale quand je lance l'anim

Message par boubouk50 » 12 Mars 2018 09:55

Je pense qu'il faut revoir simplement ton placement de bras par défaut.
L'animation à l'air d'être faite selon un certain axe (0, 0, 90), mais la position par défaut dans un autre (0, -90, 90). Mets ton bras par défaut sur le bon axe, puis lie-le à ta caméra, ou bien ajoute un parent vide qui s'occupera de réorienter correctement le bras par défaut (tourné à 90° donc).
"Ce n'est pas en améliorant la bougie, que l'on a inventé l'ampoule, c'est en marchant longtemps."
Nétiquette du forum
Savoir faire une recherche
Apprendre la programmation

Répondre

Revenir vers « Scripting Javascript, C# et Boo »