Probleme de compatibilité d'une ancienne version à la 2018

Section dédiée à la VR avec Unity
Alkyssprod
Messages : 40
Inscription : 11 Avr 2019 10:05

Probleme de compatibilité d'une ancienne version à la 2018

Message par Alkyssprod » 11 Avr 2019 12:17

Bonjour je vous écris car j'ai un soucis sur un projet que j'ai importé depuis la version 5.6 à la version 2018.

Voici les erreurs
Pièces jointes
Capture d’écran 2019-04-11 à 12.15.54.png
Capture d’écran 2019-04-11 à 12.15.54.png (284.73 Kio) Consulté 1122 fois

Avatar de l’utilisateur
boubouk50
ModoGenereux
ModoGenereux
Messages : 5439
Inscription : 28 Avr 2014 11:57
Localisation : Toulouse

Re: Probleme de compatibilité d'une ancienne version à la 2018

Message par boubouk50 » 11 Avr 2019 12:40

Les as-tu lu? Parce que c'est écrit ce qu'il faut faire.
Allow Unsafe code in Players Settings to fix this error

Sinon, dans les faits, passer de la V5 à 2018 (saut de 2 versions) pose toujours une mise à jour et/ou correction des scripts: L'obsolescence.
"Ce n'est pas en améliorant la bougie, que l'on a inventé l'ampoule, c'est en marchant longtemps."
Nétiquette du forum
Savoir faire une recherche
Apprendre la programmation

Alkyssprod
Messages : 40
Inscription : 11 Avr 2019 10:05

Re: Probleme de compatibilité d'une ancienne version à la 2018

Message par Alkyssprod » 11 Avr 2019 12:59

Merci Boubouk

Bien les scripts existent mais je ne les utilise plus.

Mais si je supprime Easymovie texture J'ai de nouvelles erreurs.

Je sais pas si il est possible d'envoyer le projet pour le rendre compatible à la version 2018 ? :(

Avatar de l’utilisateur
boubouk50
ModoGenereux
ModoGenereux
Messages : 5439
Inscription : 28 Avr 2014 11:57
Localisation : Toulouse

Re: Probleme de compatibilité d'une ancienne version à la 2018

Message par boubouk50 » 11 Avr 2019 13:28

Tous tes scripts qui utilisent EasyMovie vont râler. Il faut supprimer toutes les occurrences, tu n'as pas le choix.
"Ce n'est pas en améliorant la bougie, que l'on a inventé l'ampoule, c'est en marchant longtemps."
Nétiquette du forum
Savoir faire une recherche
Apprendre la programmation

Alkyssprod
Messages : 40
Inscription : 11 Avr 2019 10:05

Re: Probleme de compatibilité d'une ancienne version à la 2018

Message par Alkyssprod » 11 Avr 2019 13:41

Sur le même projet j'ai supprimé easy movie texture.

je vous montrerais les autres erreurs de script.

Merci Boubouk

Avatar de l’utilisateur
stigma
Messages : 1184
Inscription : 17 Nov 2012 18:29
Localisation : Perdu dans les mondes de Myst
Contact :

Re: Probleme de compatibilité d'une ancienne version à la 2018

Message par stigma » 30 Août 2020 17:13

J'avais tenté une migration de 5.6.2 vers 2017 à l'époque mais j'ai vite abandonné. Trop de corrections à faire, beaucoup trop, sans compter tous les assets obsolètes et j'en passe. Pratiquement plus rien ne fonctionnait. Le jeu n'en valais pas la chandelle et je suis resté à la 5.6.2, qui marche même en VR.

Répondre

Revenir vers « Unity et la VR »