La recherche a retourné 30 résultats

par Chandala
01 Oct 2019 02:20
Forum : L'interface GUI
Sujet : [RESOLU] Boutons de panel reconnus mais qui ne fonctionnent pas
Réponses : 11
Vues : 1839

Re: Boutons de panel reconnus mais qui ne fonctionnent pas

Problème résolu ! Cas assez singulier, les boutons Game Select avaient dans leur GameSavePanel.cs rattaché 3 valeurs ( allow loading, allow saving et allow deleting from this screen ). D'après le tutoriel, il ne fallait pas cocher le ' allow saving ' (pour ne pas pouvoir sauvegarder en étant dans le...
par Chandala
30 Sep 2019 19:03
Forum : L'interface GUI
Sujet : [RESOLU] Boutons de panel reconnus mais qui ne fonctionnent pas
Réponses : 11
Vues : 1839

Re: Boutons de panel reconnus mais qui ne fonctionnent pas

Un peu d'avancée sur ce cas ! ::d Le bouton Retour fonctionne désormais comme il se doit, il existait en fait deux fonctions " ClosePanel " et bizarrement pour ce bouton il devait passer par le MainMenuEvents.ClosePanel au lieu du GameSavePanel.ClosePanel (logique alors qu'il doit fermer le SaveAndL...
par Chandala
21 Sep 2019 21:33
Forum : L'interface GUI
Sujet : [RESOLU] Boutons de panel reconnus mais qui ne fonctionnent pas
Réponses : 11
Vues : 1839

Re: Boutons de panel reconnus mais qui ne fonctionnent pas

Je vais voir pour le script ce que je peux faire alors, comparer ses méthodes avec d'autres similaires notamment. Pour les Animators ils ne sont pas attachés aux boutons mais ils sont sur 3 panels ( FadeIn , SettingsPanel et SaveAndLoadGameFilePanel ) du coup je pensais qu'une erreur supposée à ce n...
par Chandala
21 Sep 2019 20:00
Forum : L'interface GUI
Sujet : [RESOLU] Boutons de panel reconnus mais qui ne fonctionnent pas
Réponses : 11
Vues : 1839

Re: Boutons de panel reconnus mais qui ne fonctionnent pas

Alors là, aucune idée... Je suis partie en éclaireur sur le Discord voir si d'autres avaient eu ce souci avec ce tutoriel mais pas de réponse pour le moment et dans les archives des questions, rien à signaler non plus à ce sujet. Après les boutons fonctionnent mieux en partie dans la scène Novel (le...
par Chandala
21 Sep 2019 05:19
Forum : L'interface GUI
Sujet : [RESOLU] Boutons de panel reconnus mais qui ne fonctionnent pas
Réponses : 11
Vues : 1839

Re: Boutons de panel reconnus mais qui ne fonctionnent pas

Bon matin à tous :cote: Okay donc le Debug.Log ne sert bien qu'à ça, je me disais aussi que je n'avais vu nulle part des utilisations plus précises. Parmi les méthodes que j'ai testées avec le Debug.Log, la LoadFilesOntoScreen est bien reconnue par la console lorsqu'on clique sur " Continue " pour p...
par Chandala
20 Sep 2019 15:53
Forum : L'interface GUI
Sujet : [RESOLU] Boutons de panel reconnus mais qui ne fonctionnent pas
Réponses : 11
Vues : 1839

Re: Boutons de panel reconnus mais qui ne fonctionnent pas

Merci tous les deux pour vos réponses ! Et non Max, je n'y avais pas pensé, j'ai encore du mal à comprendre comment on demande au Debug.Log ce genre de vérification plus spécifique :gene: Comment peut-on lui demander de détecter si on rentre bien dans une méthode ? :0 Les articles que j'ai lus dessu...
par Chandala
19 Sep 2019 18:02
Forum : L'interface GUI
Sujet : [RESOLU] Boutons de panel reconnus mais qui ne fonctionnent pas
Réponses : 11
Vues : 1839

[RESOLU] Boutons de panel reconnus mais qui ne fonctionnent pas

Bonjour, bonsoir à toutes et à tous ! :cote: Je reviens à vous encore une fois pour un nouveau souci avec ma Visual Novel. C'est un souci que je rencontre depuis un long moment à présent et la console n'indique aucune erreur pouvant donner une idée de sa résolution. Mon projet actuel comporte deux s...
par Chandala
12 Sep 2019 20:14
Forum : Scripting Javascript, C# et Boo
Sujet : Logiciel "d'assemblage d'images"
Réponses : 7
Vues : 1641

Re: Logiciel "d'assemblage d'images"

Coucou ! :cote: Dans les faits ça semble possible et même nécessaire selon les effets que tu veux rendre avec tes images (sait-on jamais mais par exemple si tu voulais créer un effet de brume entre le décor et le personnage de ta carte, il serait donc nécessaire de superposer les différents éléments...
par Chandala
12 Sep 2019 18:49
Forum : (C#) CSharp
Sujet : [RESOLU][DB - AL] FormatException: Input string was not in a correct format
Réponses : 17
Vues : 1713

Re: [DB - AL] FormatException: Input string was not in a correct format

Ça marche !! :pleur4: :coeur: :coeur: :coeur: J'ai reçu une réponse en même temps de quelqu'un en Allemagne ayant eu aussi ce même problème et effectivement il proposait d'utiliser un " CultureInfo.InvariantCulture " pour les paramètres chiffrés (du genre float.Parse(parameters[2], CultureInfo.Invar...
par Chandala
12 Sep 2019 18:29
Forum : (C#) CSharp
Sujet : [RESOLU][DB - AL] FormatException: Input string was not in a correct format
Réponses : 17
Vues : 1713

Re: [DB - AL] FormatException: Input string was not in a correct format

Eh bien... Ça a fonctionné, mais du coup l'erreur s'est déplacée deux lignes plus loin ici : float speed = parameters.Length >= 4 ? float.Parse(parameters[3]) : 7f; move(Character,0,3,0.7) J'imagine qu'il doit compter le 0 comme targetlocationX et le 3 comme targetlocationY . Alors j'ai mis une virg...

Aller sur la recherche avancée