Problème Tuto fps partie 1

Toutes les questions relatives aux tutoriels du site sont à poser à cet endroit.
adrixd
Messages : 4
Inscription : 13 Fév 2013 17:31

Problème Tuto fps partie 1

Message par adrixd » 13 Fév 2013 17:35

Bonjour,
Je suis nouveau sur le fofo et j'ai acheté le pack fps ^^ j'en suis ravi!
Mais j'ai un problème quand je fais play pour que mon first person bouge il traverse automatiquement a chaque fois le sol (le cube) je ne sais pas d'où cela préviens sachant que je suis novice ^^ :roll:


Merci à vous :D

Avatar de l’utilisateur
yoyoyaya
Messages : 1656
Inscription : 30 Mai 2011 13:14
Localisation : PAAAAARTOUUUU
Contact :

Re: Problème Tuto fps partie 1

Message par yoyoyaya » 13 Fév 2013 19:58

Il y a un character collider sur le perso ?
Le collider du sol n'est pas en trigger ?
ImageImage

adrixd
Messages : 4
Inscription : 13 Fév 2013 17:31

Re: Problème Tuto fps partie 1

Message par adrixd » 13 Fév 2013 20:58

yoyoyaya a écrit :Il y a un character collider sur le perso ?
Le collider du sol n'est pas en trigger ?
A vrai dire je ne sais pas du tout ce que tu me raconte... :roll:
Mais maintenant sa marche mais mon perso ne bouge plus....
EDIT: Maintenant dés que j'ouvre mon fichier il y a du violet sur mes murs.... Je dois remettre la texture à chaque fois.... :cry:

Avatar de l’utilisateur
yoyoyaya
Messages : 1656
Inscription : 30 Mai 2011 13:14
Localisation : PAAAAARTOUUUU
Contact :

Re: Problème Tuto fps partie 1

Message par yoyoyaya » 13 Fév 2013 22:19

As tu seulement regardé les tutos ?
ImageImage

adrixd
Messages : 4
Inscription : 13 Fév 2013 17:31

Re: Problème Tuto fps partie 1

Message par adrixd » 14 Fév 2013 20:22

Oui je l'ai suivi a la lettre!
Edit: résoulu!
Mais quand j'ouvre n'importe quelle fichier unity les textures sont violette/rose! C'est bisard tous sa!

Et merci ^^

EDIT: Mon perso ne bouge pas quand je fais play avec maximise on play! Alors qu'avant sa marchais sur un autre fichier....
The referenced script on this Behaviour is missing! on me dis sa....
Merci

Avatar de l’utilisateur
yoyoyaya
Messages : 1656
Inscription : 30 Mai 2011 13:14
Localisation : PAAAAARTOUUUU
Contact :

Re: Problème Tuto fps partie 1

Message par yoyoyaya » 14 Fév 2013 22:49

adrixd a écrit :Oui je l'ai suivi a la lettre!
Je viens de regarder deux secondes la partie 1 du tuto fps de krys et c'est plutôt clair niveau explications. Alors bon, avec un peu d'effort ... :)
adrixd a écrit :Mais quand j'ouvre n'importe quelle fichier unity les textures sont violette/rose! C'est bisard tous sa!
adrixd a écrit :The referenced script on this Behaviour is missing! on me dis sa....
J'ai eu ça une fois au redémarrage d'un crash complet du système. C'est quand les éléments de tes prefabs se sont barrés. Textures des matériaux, scripts etc. Seul solution que je connaisse, remettre tout à la mano. C'est incroyablement chiant quand on a plus d'un truc à remettre mais bon, a moins d'utiliser des sauvegardes, j'ai pas trouvé d'autres solutions.
Ton erreur de script, c'est comme pour tes textures/Materials, le script a été enlevé du prefab (si je ne me trompe pas et qu'il ne s'agisse pas plutôt d'une question de variable vide dans le script).
ImageImage

Avatar de l’utilisateur
krys64
Fondateur unity3d-france
Fondateur unity3d-france
Messages : 470
Inscription : 26 Nov 2009 00:08

Re: Problème Tuto fps partie 1

Message par krys64 » 14 Fév 2013 23:29

Bizarre, dezippe a nouveau le projet dans un autre dossier et ouvre le avec Unity.

adrixd
Messages : 4
Inscription : 13 Fév 2013 17:31

Re: Problème Tuto fps partie 1

Message par adrixd » 16 Fév 2013 19:27

J'ai carrement tous supprimé! Je vous tiens au courant ^^

namursite
Messages : 19
Inscription : 07 Jan 2013 11:36

Re: Problème Tuto fps partie 1

Message par namursite » 24 Avr 2013 23:33

J ai moi aussi le même message
the referenced script on this behaviour is missing
pourvez m 'aider merci http://www.wuala.com/namursite/z-galeri ... s%202.zip/
en fichiers zip , le script pour faire du streaming à partir du web
il ne charge le pas le fichier ( .unity3d ) sur le serveur ? , mais l 'autre scène .

Code : Tout sélectionner

using UnityEngine;
using System.Collections;
using System.Collections.Generic;

public class scene1 : MonoBehaviour {

	int progress;
	void Start()
	{

		string url = "http://namursite.be/1objets/scene1.unity3d";	
		StartCoroutine(StartDownloadScene(url));

	}

	void Update()
	{
     
	}

	void OnGUI()
	{
		Vector2 pos = new Vector2(20, 40);
		Vector2 size = new Vector2(360, 10);

		GUIStyle customStyle = new GUIStyle();
		Texture2D tex = new Texture2D(10, 10);
		tex.SetPixel(10, 10, Color.gray);
		customStyle.normal.background = tex;

		if (progress != 100)
		{
			GUILayout.Label(progress + "%");
			GUI.BeginGroup(new Rect(pos.x, pos.y, progress, size.y));

			// Define progress bar texture within customStyle under Normal > Background
			GUI.Box(new Rect(0, 0, size.x, size.y), "", customStyle);

			// Always match BeginGroup calls with an EndGroup call
			GUI.EndGroup();


		}
	}

IEnumerator StartDownloadScene(string url)
        {
                WWW download = new WWW(url);
                while (!download.isDone)
                {
                        //Ici on gère la barre de progression
                        progress = System.Convert.ToInt32(download.progress * 100);
                       
                        //On attend sagement la fin du téléchargement
                        yield return null;
                }
                //On charge la scène ainsi téléchargée.
                Application.LoadLevelAdditive("scene1");            
	}

	
}
krys64 , je suis content de tombé sur vous ,
vous avez souvent de bons tuyaux sur la toile :-)

merci d'avance .

Avatar de l’utilisateur
krys64
Fondateur unity3d-france
Fondateur unity3d-france
Messages : 470
Inscription : 26 Nov 2009 00:08

Re: Problème Tuto fps partie 1

Message par krys64 » 25 Avr 2013 11:25

c est simple, dans ta scene1, si tu clique sur "Terrain" dans ta hierarchy, tu verras qu il manque un script associé à un composant dans la fenetre "inspector"

Verrouillé

Revenir vers « Tutoriels du site Unity3D-france »