[RESOLU] UnityEngine.UI absent Unity 2019.2

Questions à propos du GUI, y compris la partie script.
Assis
Messages : 8
Inscription : 12 Août 2019 19:26

[RESOLU] UnityEngine.UI absent Unity 2019.2

Message par Assis » 04 Sep 2019 19:00

Bonsoir je viens à vous car mes recherches n'ont pas données de grands résultats.

Voici mon problème :
Erreur CS0234 Le nom de type ou d'espace de noms 'UI' n'existe pas dans l'espace de noms 'Unity' (vous manque-t-il une référence d'assembly ?)

Le problème est apparu après avoir fait une mise à jour, j'étais en 2018.jesaisplus. Le problème semble être présent depuis unity 2019.2, après recherche ils ont changés le nom de unityengine.UI en unityengine.ugui : https://forum.unity.com/threads/ui.673504/
Et ça pose des problèmes pour toutes les dépendances.
J'ai bien essayé de créer un nouveau projet en 2019.2.3 mais rien à faire le problème est toujours là. Alors que quelqu'un dit que en faisant ainsi le problèeme disparaissait.
Dans mes références j'ai toujours UnityEngine.UI et non ugui.
On nous parle de changer les references dans les fichiers asmdf mais je ne sais pas où ils sont, je n'ai trouvé de la doc que anglais.
Un peu d'aide ne serait pas de refus je n'ai pas trouvé de sujet relatif sur le site du forum :nono:

Avatar de l’utilisateur
Max
Newser
Newser
Messages : 7335
Inscription : 30 Juil 2011 13:57

Re: UnityEngine.UI absent Unity 2019.2

Message par Max » 04 Sep 2019 19:12

Bonsoir,

Je ne comprends pas trop ton histoire de Ugui. Dans le sujet dont tu donne le lien , Karl dit juste qu'il faut passer par le PackageManager et Importer/Mettre à jour la partie UI d'Unity.
Perso j'utilise Unity 2019.2.3f1, je n'ai pas de soucis (UnityEngine.UI).
Pas d'aide par MP, le forum est là pour ça.
En cas de doute sur les bonnes pratiques à adopter sur le forum, consulter la Charte et sa FAQ

Assis
Messages : 8
Inscription : 12 Août 2019 19:26

Re: UnityEngine.UI absent Unity 2019.2

Message par Assis » 05 Sep 2019 09:36

Bonjour,

D'après ce que j'ai compris le nom de référence qui était UnityEngine.UI est devenu UnityEngine.ugui , d'où l'erreur de référence assembly manquante
CaptureScript.png
CaptureScript.png (22.57 Kio) Consulté 236 fois
Pour le package j'ai fais reimport 3 fois mais ça ne change rien.

Oui pardon je comprends que j'ai du mal à expliquer mon problème, j'ai oublié de préciser que j'ai "upgradé" un projet mais bizzarement le même problème est présent sur un projet vierge en 19.2.3

Avatar de l’utilisateur
Max
Newser
Newser
Messages : 7335
Inscription : 30 Juil 2011 13:57

Re: UnityEngine.UI absent Unity 2019.2

Message par Max » 05 Sep 2019 11:50

Bonjour

Pour moi le namespace ugui n'existe pas. D'ailleurs la doc n'en fait mention nulle part à ma connaissance.
Assis a écrit :
05 Sep 2019 09:36
bizzarement le même problème est présent sur un projet vierge en 19.2.3
Bizarre en effet. Si j'ouvre une projet vierge avec la version 2019.2.3f1, j'ai bien le package Unity UI de présent (version 1.0.0), et en terme de script, j'ai accès sans soucis au namespace UnityEngine.UI.
Au niveau de tes références au sein de VS, tu dois l'avoir:
Image
Pas d'aide par MP, le forum est là pour ça.
En cas de doute sur les bonnes pratiques à adopter sur le forum, consulter la Charte et sa FAQ

Assis
Messages : 8
Inscription : 12 Août 2019 19:26

Re: UnityEngine.UI absent Unity 2019.2

Message par Assis » 05 Sep 2019 16:05

J'avais déjà vérifié et je l'avais bien trouvé sous le nom de UnityEngine.UI ...

Finalement j'ai mis à jour VS et le problème s'est résolu! :|
Mais je n'ai toujours pas compris le pourquoi du comment.

Répondre

Revenir vers « L'interface GUI »